Pre-Launch Maintenance
Incident Report for UmbHost
Resolved
This incident has been resolved.
Posted May 03, 2021 - 13:29 UTC
Identified
We are making some final adjustments and testing our failover pre-launch
Posted May 03, 2021 - 11:35 UTC
Investigating
We are making some final adjustments and testing our failover pre-launch
Posted May 03, 2021 - 11:34 UTC